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WEBSITES COME IN ALL SHAPES and sizes for just about every

purpose, from personal Web pages to huge corporate database-

driven resource sites. And with so much Web software it’s easy enough

to put together a few pages or even a whole site. However, making your

site fast to load, pleasing to look at and easy to navigate is something

that takes a little bit more expertise.

These short tutorials provide you with the skills you need to build

better websites from the basics, and we’ll start by looking at table

construction in Dreamweaver.We’ll then show you how to build banners,

which are excellent for leading people to new areas of your site or for

promoting your own site from other sites.

Graphic optimisation is our third tutorial, finding out just how you

can get both high quality and yet small file sizes for your Web pictures.

Even if the content on your site is superb, many people will simply not

give it a moment’s notice if your image optimisation is poor, resulting in

lengthy downloads. In fact, how many times have you given up on a

website while waiting for images to appear?

Our final mini-walkthrough looks at site navigation and how you can

use drop-down menus to make your site easy to use, while minimising

wasted screen space.

WHAT’S ON THE CD?
All the software used in this masterclass is on the cover-mounted CD

this month in the form of usable demos. Using tables is covered with

Macromedia Dreamweaver 4, while banner building is done with

Macromedia Flash 4.We optimise our images using the Adobe ImageReady
part of Photoshop 6 and the drop-down menus are created in

Macromedia Fireworks.You can do each of the things shown here using

many other types of software but we’ve chosen to use the market

leaders in this tutorial.

We’ve also put as many files as possible on the CD so that you can see

each stage of the process and also have a go yourselves.There you will

find files for the banner walkthrough, as well as those on image

optimisation and drop-down menus.

WALKTHROUGH: Build page layouts using tables in HTML

1We’re going to create a page with a fixed layout

suitable for 640 x 480 screen resolutions. First, select

the Table icon from the Dreamweaver tool palette and

enter the values for a basic layout with two rows and

three columns. In this case we’ll be using a fixed table

width of 600 pixels.

2As the construction of this table is designed as a

layout, ensure that the values for the cell padding,

cell spacing and the border are set to zero, now press OK.

The table will appear on your page. Select the top three

rows of the table and select Modify> Table> Merge Cells.

3Next, we’ll set up the column widths of the second

row of the table so that the left and right columns

can act as navigation, while the central column is used

for content.We’ll use 120 pixel widths for the left and

right columns and 360 pixels for the centre one.

4 You can start to add content into the table cells –

we’ll add a logo and some initial navigation buttons.

If you have a large page of content you can improve the

perceived speed at which it loads by breaking up the

tables. Click the Layout mode button and look at the

table you created.

5Using the Draw Layout Table button from the tool

palette, draw another table underneath the one you

have already created. As browsers progressively

download and render pages, content appears faster if it is

broken into separate tables, making this method suitable

for displaying larger pages.

6Now use the Draw Layout Cell to draw content boxes

within the Layout table.You can move cells with the

arrow keys for precise alignment.The Layout tool also

enables you to set heights and widths accurately using

the Inspector, which makes layout easier than working

with the standard table tool alone.
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1A well-animated banner made with Flash can really

attract people to your site, or you can use them on

your own sites to promote a particular area. First open a

new document in Flash, and using Modify > Movie change

the size of the movie to something appropriate, such as

550 x 60 pixels.

2We have created a simple background using vector

shapes filled with semi-transparent gradients.This is

done by using the Fill palette and selecting the colours of

your choice in the Mixer.We have added some text using

the Text tool, but have left it on the work area so that we

can move the text onto the page as an animation.

3Now you can move the text onto the stage using

tweening between keyframes. By inserting a

keyframe at a later position in the timeline and using

Insert > Create Motion Tween, you can move the text

object on the second keyframe and the tweening, or

animation between the two frames, is done for you.

1Adobe ImageReady comes with Photoshop 6 and is

excellent for compressing your images to the

optimum file size while retaining high-quality results.

Open ImageReady and open the file to be optimised. First

perform any basic graphical operations such as canvas

rotation and image cropping.These functions are

accessed from the Image menu.

2 If you are displaying an image on a Web page,

rounding off the corners of the image using the

Marquee tool can soften the appearance of the image on

the page.The easiest way is to use the Rounded Rectangle
marquee tool to draw a selection the size of the image

and then use Select > Inverse to invert the selection.

Delete it to remove the corners.

3 You’re now going to duplicate the image so that you

can make the copies different sizes – one for a

thumbnail and one as the main image for a gallery shot.

To duplicate the images select Image > Duplicate from

the menu, and then to resize each image use the Image
Size option from the Image menu.

1 The easiest way to make drop-down menus is to use

Macromedia Fireworks, which creates the JavaScript

for you. Create a new document and make the button

that you want the pop-up menu to appear from. Fireworks
includes a range of ready made button designs which

you can access from the Insert menu.

2Now select the Pop-up menu function from the

Insert menu.The dialogue box that appears enables

you to add the details into the menu that you want to

use.Type in the first sub-menu name and then beneath

enter the URL for the page that you want to link to.

3 Press the plus symbol to enter the menu item and

its URL into the panel. Add as many menu options as

you like. If you are adding URLs you can also change the

destination URL by changing the target in the pop-up

menu.This is useful if your site is using frames or if you

want the URL to open in a new menu.

156 September 2001 

MACROMEDIA

RESOURCES

www.macromedia.

com/resources/

This page is the
portal to the world
of great resources for
Macromedia product,
be it their own
services such as
Dreamweaver or
Flash exchange or
links to other sites
on the Web.

SHOCKWAVE

www.shockwave.

com/

The ultimate site for
ideas about how
dynamic media can
and should be used.

WEB REFERENCE

www.webreference.
com/
Not the most
beautiful site in the
world, but packed
with useful
information for any
website developer,
covering topics from
DHTML and XML to
3D and graphics on
the Web.

Foundation Flash 5

By Amanda Farr
ISBN: 1-90345-031-4
Price: £21.99
A good all-round
introduction to Flash
with well-balanced
tutorials which
explore techniques
not covered in most
beginner books.

Web Design in a

Nutshell

By Jennifer Niederst 
Price: £19.95
ISBN: 1-56592-515-7
This no-nonsense
guide to HTML
explains how
commands work and
covers issues such as
browser
compatibility. A
valuable resource for
discovering the
possibilities of HTML.

GOING
FURTHER

MASTERCLASS WEB SKILLS

WALKTHROUGH: How to build a banner➔

WALKTHROUGH: How to optimise your images for the Web➔

WALKTHROUGH: How to create drop-down menus ➔
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MAKE YOUR SITE INTERACTIVE
Pages of static text and graphics are lifeless and you’ll have to
work very hard to maintain them. Invest time and effort in
creating dynamic, but relevant content. Many packages can now
produce Shockwave Flash animations which provide a degree of
interactivity. Add value to your site: visit www.cgi-resources.com/
to find out how you can add scripts to your site to run interactive
searches and database your content.

USE YOUR BANDWIDTH WISELY
You’ll lose a third of your visitors on any page that takes over
eight seconds to load on a modem, which means your Web pages
should be no larger than 50KB including your graphics. Always try
to optimise your graphics and don’t make them larger than they
need to be to display what you want. Use GIF for graphics with
few colours, such as logos, or utilise Flash where possible to
provide optimum results without large downloads.

KEEP CONTENT FRESH
Use JavaScript to randomise the content loaded onto a page, and
it will attract more frequent visits. It’s worthwhile keeping a site
small with regular small updates, rather than to make a massive
site with updates which are buried within the site. Ultimately a
database-driven site will work best as content can be updated
automatically and much of the site maintenance can take care of
itself, leaving you more time to produce content.
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4Next, fade the text out of the frame by adding

another keyframe about 20 frames on in each of the

text layers. Add a motion tween as in step 3. As the text

objects are instances, you can make them transparent

with the Alpha channel. Use the Effects palette to change

the Alpha channel to 0% to make the transition smooth.

5 You can add extra text over a number of frames to

build up a series of messages on your banner, but

you may want to link each different piece of text to a

different Web page within your site. Using the Actions

Inspector you can add whatever behaviour you want to a

specific frame or object, including opening a URL.

6Now you can add the finishing touches to your

banner by adding further animation using

tweening.You will then need to test your animation –

select Control > Test Movie to check the file size before

using the Export tool to make the Flash banner into a

.SWF file.

4 First we’ll optimise the thumbnail. Click the 4up tab

from the Thumbnail document window. Use the

Optimisation palette to change each of the settings for

the four previews. Zooming in can help as you can tell

how destructive the JPEG artefacting has been.This 80-

pixel square image was reduced to 3KB, which will take

about 1-2 seconds to load on a modem.

5Using the Slicing tool from the Tool palette slice your

photograph so that the area of key interest can be

compressed to a better quality than the other, less

detailed, areas. Use the Optimise tab to set the

compression levels for each slice and check that the

quality is good enough for each slice.

6 You can now export your sliced image along with

the HTML.This will save you having to write any

HTML coding for the table construction that will load up

in the segments of the image in the right places.

Use File > Output Optimized to save your image.The

Output setting in the File menu enables you to change

the HTML output if desired.

4 To create sub-menus within your menu, press the

small indent button which pushes the selected text

in and indents it in the list.When your menu is created

the indented items will appear as separate sub-menus so

you can build hierarchical menu structures.

5When you have finished building your menus and

sub-menus press the Next button which will take

you to a screen where you can change the settings for

how the menu will appear.You can change a number of

options such as text size and font used, as well as the

menu colour.

6 If you want your menus to look more fancy, you can

use an image for the backing to the menu cells by

selecting the Image radio button.To test the menu

structure properly, select Preview in Browser from the 

File menu as the menus cannot be previewed from

within Fireworks. MF
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